More Photo Gallery Enhancements

gallery2.png

Last week I began the long overdue process of upgrading the Photo Gallery plugin to work with Movable Type 4.1. A week later I have made a number of improvements and have gotten the plugin to a point where I feel much more comfortable encouraging people to download, install and actually use it. I am using it now for my personal photo gallery - for what that is worth.

Change Log

  • The upload dialog is now completely functional
  • An upgrade function has been implemented to convert your old MT3.x galleries into Photo Gallery 2.0-compliant ones. The upgrade function right now is a URL hack, but it is simple: http://yourdomain.com/cgi-bin/mt/mt.cgi?blogid=###&_mode=PhotoGallery.upgrade

Known Issues and To Do List

  • Movable Type 4.2 users should make sure they use PG 2.01 or higher.
  • The "Stop Design Photo Gallery (HTML)" template set is not yet functional.
  • Tagging as a favorites doesn't work - I need to migrate old installs to use the @favorite tag as opposed to the Favorite Category.
  • The template set should auto install some albums for you if none exist.
  • Add a caption field for a photo
  • Favorites do not display properly on the front door
  • Upgrade comment form to use MT4's new form
  • Paginate category archives by month somehow

Recommended Entries

12 Comments

Whatever happened to your plugin manager? A lot of sites link to it, but it seems to lead to a non-existent page.

Thanks so much for all your great work with MT!

I really do hope to revive Plugin Manager. It was originally developed while I was working on another project at Six Apart, and when I became the Product Manager of Movable Type my priorities changed.

Realizing that I had the opportunity to address some deeper, lower-level issues with the product I put PM on hold and began to focus on what it would take not to make MT better in just a single area, but more holistically. That gave rise to MT4 and then all of the renewed excitement around the platform.

I will return to PM one day - but right now, the emphasis is on themes and template sets and making MT easier and easier to use.

Hello,

there is another bug : meta/img does not exist in the published folder after installation.

best

mahi

Byrne -

Does the new Photo Gallery plugin require MT4 Commercial (with the Professional pack for custom fields) or will it work with MTOS?

Thanks,

Isaac

The Photo Gallery templates ABSOLUTELY work with MTOS. Yay!

Out of curiosity, does this version support larger image sizes or a slightly easier method than 1.7 for changing them?

@Alex - It should yes.

I am having trouble installing this on MT4 as I'm a GM ex-user and MT virgin. I tried following the instructions on the previous manual - for MT3.+, but somehow can't load the plugin? I really would love this feature.

I wish I were smarter. :(

I am not sure what I am doing wrong with this. I am running 4.12 MTOS on linux.

I installed the plugin (v2.01) to my cgibin and mt-static directories.

I then created a new blog (with your PHP templates.) I changed the blog archive entry to PHP.

I then created a couple of albums.

I then uploaded a picture into one album.

I then publish the site.

All I get is a blank page (all white.)

I then manually traverse the directory via Firefox, every page is blank all the way down to the picture I loaded:

../photo/hawaii/gallery/lonely_surfboard.php

How do I get something to show up?

Thanks!

Hi I love these galleries.

I just tried to install v2.01 on MT 4.2, and the install went fine and I can create a photoblog, but when I view it I get a 500 error.

Any ideas for how I should troubleshoot? I am an absolute rookie, by the way.

Thanks!!

Scott

I'm having the SAME PROBLEM as Scott above. Can you please post a reply?

What else causes the 500 error on view when all your permissions are right?

I am having difficulty getting your plugin to work. I am a longtime fan of your various plugins, and of Doug Bowman's work on these templates, having used them for a client back in 2005 when they were first released. Along with the Photon plugin for iPhoto, this was a great utility! Alas, alack, the support over the years has diminished.

Undaunted and eager to see it live again, I have installed the Photo Gallery 2.01 plugin to a working version of MT4.2. It appears however that the plugin is generating a bad ROOT_PATH, at least on my server with Media Temple. I've tried changing the SITE ROOT for this configuration but it still comes up wrong.

Is there reason to hope for the plugin and support to be revitalized?

Best, Jesse B.

Leave a comment

what will you say?


Recent Comments

  • I am having difficulty getting your plugin to work. I am a longtime fan of your various plugins, and of Doug Bowman's work on these templates, having used them for a client back in 2005 when they were first released. Alo...

  • I'm having the SAME PROBLEM as Scott above. Can you please post a reply? What else causes the 500 error on view when all your permissions are right? ...

  • Hi I love these galleries. I just tried to install v2.01 on MT 4.2, and the install went fine and I can create a photoblog, but when I view it I get a 500 error. Any ideas for how I should troubleshoot? I am an absolut...

  • I am not sure what I am doing wrong with this. I am running 4.12 MTOS on linux. I installed the plugin (v2.01) to my cgibin and mt-static directories. I then created a new blog (with your PHP templates.) I changed ...

  • I am having trouble installing this on MT4 as I'm a GM ex-user and MT virgin. I tried following the instructions on the previous manual - for MT3.+, but somehow can't load the plugin? I really would love this feature. I...

Close